Map Composer Getötet

Diskussionen zu dem Werkzeug hinter der Karte und für eigene Garminkarten
Antworten
Benutzeravatar
mtb-Herten
Beiträge: 156
Registriert: Fr Jan 11, 2019 9:51 pm

Map Composer Getötet

Beitrag von mtb-Herten » Di Feb 23, 2021 8:46 pm

Hallo zusammen,

beim aktuellen Lauf meldet Map Composer Getötet und bricht den Lauf ab.

Code: Alles auswählen

mtbbiker99@mtbbiker99:~/01-mtb-V2$ java -Xmx7500M -cp map_composer.jar:ndsc18.jar:nop.jar:colorpicker.jar:bzip2.jar:jai_codec.jar:protobuf-java.jar:osmosis-osm-binary.jar nop.osmc.MapComposer
11.0.10
Table IDManager loaded in 2 ms
Table Settings loaded in 14 ms
Gtk-Message: 20:30:15.917: Failed to load module "canberra-gtk-module"
Table Planet loaded in 33 ms
Table Regions loaded in 6 ms
Table Layer loaded in 2 ms
Table GarminDef loaded in 34 ms
Table GarminItem loaded in 19 ms
Table MapItem loaded in 18 ms
Table ConvertRule loaded in 2 ms
Table ConvertAction loaded in 4 ms
Table Outline loaded in 2 ms
Table Route loaded in 22 ms
Table Level loaded in 3 ms
Table Profile loaded in 0 ms
Table TagFilter loaded in 5 ms
written 71674429
Time for analysis 185 sec
rate 6870 (6870) queue: 320 l=33921
rate 21901 (14385) queue: 42 l=9499
rate 25201 (17990) queue: 501 l=5401
rate 27995 (20491) queue: 484 l=3244
rate 25720 (21537) queue: 501 l=2161
Replacing distance Infinity with 0
rate 28169 (22642) queue: 50 l=1546
rate 22820 (22668) queue: 322 l=1258
rate 28555 (23403) queue: 478 l=1011
rate 28555 (23976) queue: 501 l=830
Replacing distance Infinity with 0
rate 29171 (24495) queue: 501 l=752
rate 28011 (24815) queue: 112 l=588
rate 25354 (24860) queue: 482 l=509
rate 26737 (25004) queue: 501 l=438
rate 27548 (25186) queue: 501 l=414
rate 29377 (25465) queue: 501 l=432
rate 30674 (25791) queue: 501 l=193
rate 27578 (25896) queue: 473 l=120
rate 37009 (26513) queue: 501 l=112
rate 28360 (26610) queue: 501 l=123
rate 30769 (26818) queue: 496 l=160
Replacing distance Infinity with 0
rate 29256 (26934) queue: 501 l=188
Replacing distance Infinity with 0
rate 24390 (26819) queue: 501 l=176
rate 29325 (26928) queue: 501 l=153
rate 27624 (26957) queue: 501 l=190
rate 27322 (26971) queue: 476 l=241
rate 23640 (26843) queue: 314 l=236
rate 29359 (26936) queue: 500 l=137
rate 25893 (26899) queue: 501 l=180
rate 23212 (26772) queue: 483 l=154
rate 29779 (26872) queue: 391 l=102
rate 20128 (26654) queue: 501 l=146
rate 26329 (26644) queue: 495 l=131
rate 14762 (26284) queue: 501 l=130
rate 29673 (26384) queue: 501 l=198
rate 25813 (26367) queue: 458 l=148
rate 20259 (26198) queue: 501 l=128
rate 18532 (25991) queue: 455 l=132
rate 35410 (26238) queue: 501 l=142
rate 30156 (26339) queue: 501 l=148
rate 29603 (26420) queue: 498 l=145
rate 29832 (26504) queue: 407 l=95
rate 33288 (26665) queue: 501 l=101
rate 27412 (26683) queue: 134 l=91
rate 21195 (26558) queue: 501 l=109
rate 38729 (26828) queue: 501 l=94
rate 18450 (26646) queue: 501 l=73
rate 25329 (26618) queue: 501 l=108
rate 28985 (26667) queue: 499 l=95
rate 32701 (26791) queue: 485 l=98
rate 29498 (26845) queue: 501 l=106
rate 31036 (26927) queue: 496 l=133
rate 28985 (26966) queue: 501 l=98
rate 21340 (26860) queue: 442 l=79
rate 9345 (26536) queue: 501 l=60
rate 8024 (26199) queue: 342 l=94
Getötet
mtbbiker99@mtbbiker99:~/01-mtb-V2$ 

commands.log:

Code: Alles auswählen

rem Cutting data with osmosis

java -Xmx1100M -cp /home/mtbbiker99/01-mtb-V2/Tools/lib/default/osmosis-core-0.43.1.jar:/home/mtbbiker99/01-mtb-V2/Tools/lib/default/commons-compress-1.4.1.jar:/home/mtbbiker99/01-mtb-V2/Tools/lib/default/osmosis-pbf-0.43.1.jar:/home/mtbbiker99/01-mtb-V2/Tools/lib/default/protobuf-java-2.4.1.jar:/home/mtbbiker99/01-mtb-V2/Tools/lib/default/commons-logging-1.1.1.jar:/home/mtbbiker99/01-mtb-V2/Tools/lib/default/osmosis-areafilter-0.43.1.jar:/home/mtbbiker99/01-mtb-V2/Tools/lib/default/osmosis-osm-binary-0.43.1.jar:/home/mtbbiker99/01-mtb-V2/Tools/lib/default/jpf-1.5.jar:/home/mtbbiker99/01-mtb-V2/Tools/lib/default/osmosis-core-0.43.1.jar:/home/mtbbiker99/01-mtb-V2/Tools/lib/default/osmosis-xml-0.43.1.jar org.openstreetmap.osmosis.core.Osmosis --read-bin file=/home/mtbbiker99/01-mtb-V2/intermediate/nordrhein-westfalen.osm.pbf --bounding-box bottom=50.4 left=5.9 top=52.5 right=9.8 clipIncompleteEntities=yes --write-pbf file=/home/mtbbiker99/01-mtb-V2/input/mtb4_input.osm.pbf omitmetadata=true 

Feb. 23, 2021 8:30:57 NACHM. org.openstreetmap.osmosis.core.Osmosis run
INFORMATION: Osmosis Version 0.43.1
Feb. 23, 2021 8:30:57 NACHM. org.openstreetmap.osmosis.core.Osmosis run
INFORMATION: Preparing pipeline.
Feb. 23, 2021 8:30:57 NACHM. org.openstreetmap.osmosis.core.Osmosis run
INFORMATION: Launching pipeline execution.
Feb. 23, 2021 8:30:57 NACHM. org.openstreetmap.osmosis.core.Osmosis run
INFORMATION: Pipeline executing, waiting for completion.
Feb. 23, 2021 8:34:17 NACHM. org.openstreetmap.osmosis.core.Osmosis run
INFORMATION: Pipeline complete.
Feb. 23, 2021 8:34:17 NACHM. org.openstreetmap.osmosis.core.Osmosis run
INFORMATION: Total execution time: 200413 milliseconds.
Eine Error Datei gibt es nicht.

Wo kann ich den Fehler suchen?
Benutzeravatar
Nop
Site Admin
Beiträge: 390
Registriert: Do Jan 10, 2019 8:46 pm

Re: Map Composer Getötet

Beitrag von Nop » Di Feb 23, 2021 9:34 pm

Du baust das unter Linux? Dann kann ich leider nichts dazu sagen.

Außer daß die Fehlermeldung Failed to load module "canberra-gtk-module" ganz am Anfang nicht rein gehört.

Würde dem mal nachgehen und nachsehen ob ihm der Speicher ausgegangen ist.
Benutzeravatar
mtb-Herten
Beiträge: 156
Registriert: Fr Jan 11, 2019 9:51 pm

Re: Map Composer Getötet

Beitrag von mtb-Herten » Mi Feb 24, 2021 8:20 pm

Nur zur Info:

Diese Fehlermeldung ist harmlos und hat keinen Einfluss auf den map composer.
Damit arbeitet ich schon seit 2018.
Dennoch habe ich den Fehler wegbekommen. Mit diesem Befehl:

Code: Alles auswählen

sudo apt install libcanberra-gtk-module libcanberra-gtk3-module
Quelle: https://praxistipps.chip.de/ubuntu-fail ... tun_108785

Es ist zwar die Fehlermeldung "Gtk-Message: 20:30:15.917: Failed to load module "canberra-gtk-module"" verschwunden, aber der Lauf
wurde nach wie vor mit Getötet abgebrochen.

Die gleiche Map Composer Instand läuft merkwürdigerweise auf meinem (schwächeren) Linux-Server ohne Probleme durch.
(Ich habe den gesamten map composer Ordner kopiert)
Da werde ich mal weiter in die Forschung gehen, ist wohl ein lokales Problem.

Gruß Oliver

Nachtrag: in der Routen Datei waren kryptische Zeichen, wo immer die auch herkommen. Diese habe ich jetzt entfernt.
Ich habe jetzt einen neuen Lauf gestartet, bin mal gespannt....
Antworten