"No overview map found"

Diskussionen zu dem Werkzeug hinter der Karte und für eigene Garminkarten
Antworten
Gast

"No overview map found"

Beitrag von Gast » Fr Jan 11, 2019 10:01 pm

[johnassel schrieb am 05.03.13 23:30]
Hallo,
ich versuche gerade einen eigenen Satz Karten zu generieren. Der Prozess läuft
soweit durch, bis er, nachdem mkgmap fertig ist, mit "No overview map found"
abbricht. Was will mir dieser Fehler sagen? Einen Hinweise in den Einstellung
o.ä. was das sein könnte habe ich nicht gefunden.
Das Log von Map Composer:

Code: Alles auswählen

Rebuilding View Renderregeln/order
Rebuilding View Renderregeln/order
Rebuilding View Renderregeln/order
Rebuilding View Renderregeln/order
Rebuilding View Renderregeln/order
Calling mkgmap to create map
Build the garmin maps
calling mkgmap
mkgmap done
No overview map found.
Map creation failed for Luxemburg_00065_0488_10_20_garmin.osm -> 40002.img
Generation finished
Saving table Settings
Updating record 2 in index Nummernkreise/nach Name
Updating record 2 in View Nummernkreise
Saving table MapItem
Updating record 99 in index Nummernkreise/nach Name
Updating record 99 in View Nummernkreise
Saving table IDManager
Und von der Konsole:

Code: Alles auswählen

Table IDManager loaded in 0 ms
Table Settings loaded in 0 ms
Table Planet loaded in 36 ms
Table Regions loaded in 0 ms
Table Segment loaded in 0 ms
Table Layer loaded in 0 ms
Table GarminDef loaded in 83 ms
Table GarminItem loaded in 16 ms
Table MapItem loaded in 0 ms
Table ConvertRule loaded in 0 ms
Table ConvertAction loaded in 0 ms
Table Outline loaded in 0 ms
Table Route loaded in 15 ms
Table Level loaded in 0 ms
Table Profile loaded in 0 ms
Table TagFilter loaded in 16 ms
Table Density loaded in 179 ms
creating segment Luxemburg_00065_0488_10_20 nodes=4766353
creating segment Luxemburg_00055_0488_10_20 nodes=5253029
05.03.13 23:27 No overview map found.
05.03.13 23:27 Map creation failed for Luxemburg_00065_0488_10_20_garmin.osm ->
40002.img
Was läuft da schief?


Zuletzt bearbeitet am 05.03.13 23:31
Gast

Re: "No overview map found"

Beitrag von Gast » Fr Jan 11, 2019 10:01 pm

[Nop schrieb am 06.03.13 07:59]

Hi!

Die entscheidende Zeile ist
Zitat:05.03.13 23:27 Map creation failed for
Luxemburg_00065_0488_10_20_garmin.osm ->
40002.img
D.h. mkgmap hatte ein Problem. Die Fehlermeldung von mkgmap findest Du in der
Dateicommands.log

bye, Nop
Gast

Re: "No overview map found"

Beitrag von Gast » Fr Jan 11, 2019 10:01 pm

[johnassel schrieb am 06.03.13 10:16]
Ah, stimmt - laut commands.log hatte mkgmap Probleme mit den Daten pro Kachel.
Zitat:There is not enough room in a single garmin map for all the input data
The .osm file should be split into smaller pieces first.Ich habe den Wert wie
in der Wiki angegeben runtergesetzt, der Vorgang bricht dennoch ab. Allerdings
ist der ursprüngliche Fehler jetzt verschwunden, stattdessen steht in der
commands.log nur noch folgendes:

Code: Alles auswählen


reg delete "HKEY_LOCAL_MACHINESOFTWAREWow6432NodeGarminMapSourceFamiliesOSM 
Luxemburg" /f

FEHLER: Der angegebene Registrierungsschlssel bzw. Wert wurde nicht gefunden.

rem Creating contour file Luxemburg_00055_0488_6_10_contour.osm

rem Creating contour file Luxemburg_00055_0498_7_4_contour.osm

rem Creating contour file Luxemburg_00055_0502_7_6_contour.osm

rem Creating contour file Luxemburg_00061_0488_5_10_contour.osm

rem Creating contour file Luxemburg_00062_0498_4_10_contour.osm

rem Creating contour file Luxemburg_00066_0488_9_6_contour.osm

rem Creating contour file Luxemburg_00066_0494_9_5_contour.osm

rem Creating contour file Luxemburg_00066_0499_9_4_contour.osm

rem Creating contour file Luxemburg_00066_0503_9_5_contour.osm

rem Build the garmin maps

java -Xmx6440M -jar D:Garmin_Mapsmap_composer_091mkgmapmkgmap.jar --tdbfile 
--preserve-element-order --route --remove-short-arcs -c 
D:Javamap_composertestdataosmc_options
Auch Konsole und das Log geben nicht viel mehr her.
Konsole:

Code: Alles auswählen

creating segment Luxemburg_00066_0503_9_5 nodes=1022255
creating segment Luxemburg_00066_0499_9_4 nodes=997196
creating segment Luxemburg_00066_0494_9_5 nodes=1249343
creating segment Luxemburg_00066_0488_9_6 nodes=1091811
creating segment Luxemburg_00062_0498_4_10 nodes=1042261
creating segment Luxemburg_00055_0502_7_6 nodes=799550
creating segment Luxemburg_00055_0498_7_4 nodes=1146209
creating segment Luxemburg_00061_0488_5_10 nodes=1355628
creating segment Luxemburg_00055_0488_6_10 nodes=1315129
06.03.13 09:51 Map creation failed for Luxemburg_00055_0498_7_4_garmin.osm -> 
40
002.img
06.03.13 09:51 Map creation failed for Luxemburg_00055_0502_7_6_garmin.osm -> 
40
003.img
06.03.13 09:51 Map creation failed for Luxemburg_00061_0488_5_10_garmin.osm -> 
4
0004.img
06.03.13 09:51 Map creation failed for Luxemburg_00062_0498_4_10_garmin.osm -> 
4
0005.img
06.03.13 09:51 Map creation failed for Luxemburg_00066_0488_9_6_garmin.osm -> 
40
006.img
06.03.13 09:51 Map creation failed for Luxemburg_00066_0494_9_5_garmin.osm -> 
40
007.img
06.03.13 09:51 Map creation failed for Luxemburg_00066_0499_9_4_garmin.osm -> 
40
008.img
06.03.13 09:51 Map creation failed for Luxemburg_00066_0503_9_5_garmin.osm -> 
40
009.img
Log:

Code: Alles auswählen

Rebuilding View Renderregeln/order
Rebuilding View Renderregeln/order
Rebuilding View Renderregeln/order
Rebuilding View Renderregeln/order
Rebuilding View Renderregeln/order
Rebuilding View Renderregeln/order
Calling mkgmap to create map
Build the garmin maps
calling mkgmap
mkgmap done
Map creation failed for Luxemburg_00055_0498_7_4_garmin.osm -> 40002.img
Map creation failed for Luxemburg_00055_0502_7_6_garmin.osm -> 40003.img
Map creation failed for Luxemburg_00061_0488_5_10_garmin.osm -> 40004.img
Map creation failed for Luxemburg_00062_0498_4_10_garmin.osm -> 40005.img
Map creation failed for Luxemburg_00066_0488_9_6_garmin.osm -> 40006.img
Map creation failed for Luxemburg_00066_0494_9_5_garmin.osm -> 40007.img
Map creation failed for Luxemburg_00066_0499_9_4_garmin.osm -> 40008.img
Map creation failed for Luxemburg_00066_0503_9_5_garmin.osm -> 40009.img
Generation finished
Saving table Settings
Updating record 2 in index Nummernkreise/nach Name
Updating record 2 in View Nummernkreise
Saving table MapItem
Updating record 99 in index Nummernkreise/nach Name
Updating record 99 in View Nummernkreise
Saving table IDManager
Ich werde mal versuchen, mkgmap im Debug-Modus auszuführen, vielleicht bringt
das mehr Informationen.

Edit: Hmmm, irgendwas hat die Backslashes gefressen...


Zuletzt bearbeitet am 06.03.13 10:18
Gast

Re: "No overview map found"

Beitrag von Gast » Fr Jan 11, 2019 10:01 pm

[Nop schrieb am 06.03.13 12:11]
mkgmap hat scheinbar funktioniert, aber die Kartenimages werden trotzdem nicht
gefunden. Sieht nach einem Problem mit der Karten-ID aus - die Images müßten
8-stellige Ziffern als Name haben, ´Composer sucht aber hier nur nach
5-stelligen.

- liegen die .img-Dateien im konfigurierten Karten-Ausgangsverzeichnis?
- wie heißen sie?
- was hast Du als "Dateiname" im Reiter "Parameter" beim Job eingestellt?
- Hast Du die Anleitungsseite dazu gelesen?
http://composer.waldpfa.de/index.php/MC/Karten
<http://composer.waldpfa.de/index.php/MC/Karten>



Zuletzt bearbeitet am 06.03.13 12:17
Gast

Re: "No overview map found"

Beitrag von Gast » Fr Jan 11, 2019 10:01 pm

[johnassel schrieb am 06.03.13 13:14]
Ja, die Anleitung hatte ich gelesen. Das Problem war der Dateiname in den
Parametern des Jobs. Ich hatte zwar 4 Ziffern, allerdings in dem Format
0001,0002 etc. Irgendwie sind beim speichern des Profils immer die Nullen
gelöscht und drei Leerzeichen angehangen worden. Als ich den Namen in das
Format 1001, 1002 etc geändert hatte, lief es problemlos durch.
Danke nochmal für die Hilfe! :-)
Antworten