Seite 1 von 1

Ersetzung will nicht recht funktionieren, Anzeige von zusätzlichern Punkten

Verfasst: Fr Jan 11, 2019 10:04 pm
von Gast
[Peter_Preis schrieb am 28.12.18 08:48]
Liebe Forenleute!

Vor Weihnachten habe ich mit dem MapComposer begonnen und bin begeistert!

Nach kleinen Schwierigkeiten habe ich begonnen die karte meinen Bedürfnissen
entsprechend anzupassen. Icon geändert, Farben abgeändert, etc. Alles klappt
sehr gut.

Jetzt habe ich festgestellt, das von Haus auf der generierten Karte nicht alle
Objekte angezeigt werden, welche ich gern hätte.

Konkret sind das einzeln stehende Felsen. In OSM werde diese mit: natural=rock
getaggt.

Jetzt hat der MapComposer ja die Ersetzungen. Und wenn ich es recht verstehe,
kann ich das nutzen, um eben einen solchen Punkt in einen anderen Typ zu
wandeln, welcher dann angezeigt wird.


Mein Plan ist folgender: Zum Test eine Ersetzung erstellen, welche die
Bedingung hat "Tag = Natural" "Wert = rock". Aktion: "Tag setzten" Ersatz Tag
"tourism = viewpoint"
Jetzt sollte es so sein, vorausgesetzt meine Denkweise ist korrekt, das in der
generierten Karte für jeden Punkt "Felsen" das Icon für den Viewpoint angezeigt
wird, da mit der Ersetzung quasi ein "Fels" zu einem "Aussichtspunkt" wird.

Leider funktioniert das nicht....

Was mache ich falsch? Ist meine Denkweise schon grundsätzlich falsch?


Dank & Gruß,
Peter

Re: Ersetzung will nicht recht funktionieren, Anzeige von zusätzlichern Punkten

Verfasst: Fr Jan 11, 2019 10:04 pm
von Gast
[Nop schrieb am 28.12.18 12:54]
Deine Überlegung ist richtig - der Fehler muß im Detail stecken.

Ist bei der Ersetzungsregel das Häkchen "POI" gesetzt? (es sind punktförmige
Felsen, oder?)
Schieb die neue Regel mal ganz nach oben (Mit Ctrl-Pfeil), so stellst Du
sicher daß nicht eine andere Regel zuerst zuschlägt.

Re: Ersetzung will nicht recht funktionieren, Anzeige von zusätzlichern Punkten

Verfasst: Fr Jan 11, 2019 10:04 pm
von Gast
[Peter_Preis schrieb am 29.12.18 08:26]
Hallo,

also, ich habe alles gelöscht und nochmals angelegt. Die Hinweise von NOP
beachtet, ja, POI war angeklickt und ja, die Felsen sind einzelne Punkte.

Und jetzt funktioniert es auch! :)


Dank & Gruß